Τρόπος αναγκαστικής χρήσης νήματος ή NPM

Σε αυτήν τη σύντομη ανάρτηση, θα σας δείξω πώς να αποτρέψετε τη χρήση npm ή νήματος, ανάλογα με τις ανάγκες σας. Ας αρχίσουμε!

Επεξεργασία .npmrc

Ίσως να μην έχετε αυτό το αρχείο στη βάση κώδικα. Εάν συμβαίνει αυτό, δημιουργήστε αυτό το αρχείο στον ριζικό φάκελο της εφαρμογής σας.

Μας επιτρέπει να καθορίσουμε διαμορφώσεις διαχειριστή πακέτων και χρησιμοποιείται τόσο από τα npm όσο και από τα νήματα .

Το .npmrcαρχείο σας θα πρέπει να φέρει την engine-strictιδιότητα ως true.

//.npmrc file engine-strict = true

Αυτή η επιλογή λέει στον διαχειριστή πακέτων να χρησιμοποιήσει την έκδοση των μηχανών που έχουμε καθορίσει στο package.jsonαρχείο.

Επεξεργασία package.json

Μέσα στο package.jsonαρχείο σας θα πρέπει να προσθέσετε την enginesενότητα εάν δεν το έχετε αυτήν τη στιγμή.

 //package.json { ... "engines": { "npm": "please-use-yarn", "yarn": ">= 1.19.1" }, ... }

Στον παραπάνω κώδικα, το package.jsonαρχείο χρησιμοποιεί μια έκδοση yarn1.19.1 ή μεγαλύτερη.

Αλλά για npmνα καθορίσουμε μια έκδοση που δεν υπάρχει.

Με αυτόν τον τρόπο διασφαλίζουμε ότι όταν κάποιος προσπαθεί να χρησιμοποιήσει npmαντί yarn, θα λάβει ένα σφάλμα που εξάγει please-use-yarn».

Εκτελείται εγκατάσταση npm

Μόλις πραγματοποιήσετε τις παραπάνω αλλαγές, προσπαθήστε να εκτελέσετε npm install.

Θα λάβετε ένα σφάλμα που σας εμποδίζει να χρησιμοποιήσετε npm.

 npm ERR! code ENOTSUP npm ERR! notsup Unsupported engine for [email protected]: wanted: {"npm":"please-use-yarn","yarn":">= 1.19.1"} (current: {"node":"12.16.3","npm":"6.14.4"}) npm ERR! notsup Not compatible with your version of node/npm: [email protected] npm ERR! notsup Not compatible with your version of node/npm: [email protected] npm ERR! notsup Required: {"npm":"please-use-yarn","yarn":">= 1.19.1"} npm ERR! notsup Actual: {"npm":"6.14.4","node":"12.16.3"} npm ERR! A complete log of this run can be found in: npm ERR! C:\Users\YourUser\AppData\Roaming\npm-cache\_logs\2020-05-21T10_21_04_676Z-debug.log 

Αυτό, φυσικά, μπορεί να γίνει το αντίθετο αν θέλετε να αποτρέψετε τη χρήση του yarn.

συμπέρασμα

Είναι αρκετά απλό και εύκολο να διασφαλιστεί ότι μόνο ένας διαχειριστής πακέτων πρέπει να χρησιμοποιείται μέσα στο έργο σας.

Αυτό θα μειώσει την πιθανότητα σφαλμάτων που προκαλούνται από προγραμματιστές που χρησιμοποιούν διαφορετικούς διαχειριστές πακέτων και είναι καλή πρακτική να τυποποιήσετε τους κανόνες και τη διαχείριση κωδικοποίησης του έργου.

Μπορείτε να επικοινωνήσετε μαζί μου και να με ρωτήσετε οτιδήποτε στο Twitter, στο Facebook και στον ιστότοπό μου.